Response time (web) (High)
Incident Report for Papershift
Resolved
This incident has been resolved.
Posted Mar 05, 2023 - 10:51 CET
Investigating
We are currently investigating this issue.
Posted Mar 05, 2023 - 08:14 CET