Maintenance in Progress
Incident Report for Papershift
Resolved
This incident has been resolved.
Posted Aug 18, 2023 - 02:17 CEST
Update
We are continuing to work on a fix for this issue.
Posted Aug 17, 2023 - 23:25 CEST
Identified
Dear Users,

We are currently performing maintenance on our website. During this time, the website may be temporarily unavailable or have extremely high loading times. We apologize for any inconvenience this may cause.

Thank you for your understanding and patience.
Posted Aug 17, 2023 - 23:24 CEST
This incident affected: Web Applikation.