Response time (web) (High)

Incident Report for Papershift

Resolved

This incident has been resolved.
Posted Apr 25, 2022 - 13:50 CEST

Investigating

We are currently investigating this issue.
Posted Apr 25, 2022 - 09:12 CEST