Currently there are performance problems with Cloudflare, which can also lead to performance problems with Papershift.
Incident Report for Papershift GmbH
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 02, 2019 - 16:13 CEST
Identified
Posted 4 months ago. Jul 02, 2019 - 15:51 CEST