Average Response Time (High)
Incident Report for Papershift
Resolved
This incident has been resolved.
Posted Sep 17, 2020 - 10:48 CEST
Investigating
We are currently investigating this issue.
Posted Sep 17, 2020 - 10:42 CEST