Response time (web) (High)
Incident Report for Papershift
Resolved
This incident has been resolved.
Posted May 04, 2021 - 13:51 CEST
Investigating
We are currently investigating this issue.
Posted May 04, 2021 - 12:17 CEST