Error percentage (High)
Incident Report for Papershift
Resolved
This incident has been resolved.
Posted Nov 12, 2020 - 12:59 CET
Investigating
We are currently investigating this issue.
Posted Nov 12, 2020 - 12:39 CET